Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 22, 2026 - 21:00 EDT
Scheduled
Several enterprise systems will be unavailable for several hours between 9 p.m. on Friday, May 22, and 7 a.m. on Saturday, May 23, while Pitt Digital performs system maintenance on the University’s Central Directory Service (CDS). This maintenance will not affect logins to your devices or logins to most University services.
These services may be unavailable for up to two hours during the maintenance:
• Account Self-Service (accounts.pitt.edu), including password changes and new account activations • Panther Central ID Center, including new ID card activations • Find People (find.pitt.edu) • Some online help forms at digital.pitt.edu
Users do not need to take any action before or after the maintenance. The maintenance window was scheduled by Pitt Digital after spring term to minimize any potential disruption to the Pitt community, and is part of vendor-recommended quarterly patching to ensure the continued reliability and stability of the system.
Pitt Digital has completed checks to ensure that the system is ready for the upgrade and will be actively engaged throughout the maintenance period. In the unlikely event that an issue or problem arises, the system will be reverted to its original configuration and an update posted to https://status.pitt.edu. The system will be returned to service earlier if the maintenance work is completed ahead of schedule.
Please submit a ticket to the Technology Help Desk at https://digital.pitt.edu/helprequest or call +1- 412-624-HELP (4357) if you experience any issues or have any questions regarding this upgrade.
Posted May 20, 2026 - 09:48 EDT
This scheduled maintenance affected: Accounts, Access, and Information Security (Account Management (accounts.pitt.edu), Find People (find.pitt.edu)).