Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 18, 2026 - 20:00 EDT
Scheduled
Pitt Digital will be performing network infrastructure upgrades during four remaining overnight maintenance windows in June and July from 8 p.m. to 4 a.m. on each date.
During these periods, the buildings listed below may experience one or more brief, intermittent interruptions — typically around 15 minutes — to PittNet Wi-Fi, wired connectivity, telephony, and related network services, including internet access to cloud providers and external resources, as well as remote access via PittNet Virtual Private Network (GlobalProtect). MyResNet Wi-Fi service is not impacted.
Thursday, June 18 (8 p.m. – 4 a.m.) - Alumni Hall - Bakery Square - Baum Boulevard - Bellefield Hall - Cathedral of Learning - Center Plaza - Clapp Hall - Community Engagement Center-Homewood - Craig Hall - Crawford Hall - Energy Innovation Center - Forbes-Craig Apartments - Heinz Chapel - Information Sciences Building - Langley Hall - Lexington Tech Park - Life Sciences Annex - Melwood Maintenance Building - Music Building - Ruskin Hall - Schenley Place - Stephen Foster Memorial - The Assembly (5051 Center Avenue) - Thomas Boulevard - VA Pittsburgh Healthcare System - Webster Hall
Thursday, June 25 (8 p.m. – 4 a.m.) - Allen Hall - Amos Hall - Benedum Hall - Campus Recreation and Wellness Center - Falk School - Fraternity Housing Complex - Gardner Steel Conference Center - Irvis Hall - Nordenberg Hall - O’Hara Student Center - Old Engineering Hall - Panther Hall - Soldiers & Sailors Memorial Hall - Space Research Coordination Center - Thaw Hall - University Club - University Hall - Van de Graaff Building
Thursday, July 2 (8 p.m. – 4 a.m.) - Arena & Sports Performance Center - Brackenridge Hall - Bruce Hall - Carrillo Street Steam Plant - Charles L. Cost Sports Center - Crabtree Hall - Darragh Street Apartments - Eureka Building - Fitzgerald Field House - Holland Hall - Litchfield Towers A/B/C - Lothrop Hall - McCormick Hall - Murdoch Building - Oak Hill Commons - Petersen Events Center - Petersen Sports Complex - Public Health Building - Public Safety Building - Scaife Hall - Towerview Garage - Trees Hall - Upper Campus Central Utility Plant - Victoria Building
Pitt Digital scheduled these windows late at night after spring term to minimize disruption to campus operations. The team will monitor all maintenance and post updates to https://status.pitt.edu if significant changes or delays occur.
If any of these windows conflict with a critical activity in your area, or if you experience issues or have questions, please submit a ticket to the Technology Help Desk at https://digital.pitt.edu/helprequest or call +1-412-624-HELP (4357).
Posted Jun 15, 2026 - 08:42 EDT
This scheduled maintenance affected: Wired and Wi-Fi Networks (PittNet Wired Network, Eduroam, PittNet Wi-Fi, Pitt Guest Wi-Fi), Network, Hosting, and Storage (PittNet VPN (GlobalProtect)), and Communication and Collaboration (Voice and Data Services (Telephony)).