Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 18, 2026 - 20:00 EDT
Scheduled
PantherExpress will be unavailable tonight, May 18, from 8–9 p.m. for scheduled maintenance. Please complete all transactions, save your work, and exit the system before 8 p.m. Any unsaved work will be lost when the system goes offline.
This maintenance is necessary to maintain system performance and reliability. The PantherExpress Team will monitor the upgrade in coordination with the vendor (Jaggaer). If issues arise or the outage extends beyond the scheduled window, updates will be posted to https://status.pitt.edu.
For questions, contact Purchase, Pay & Travel Customer Service at pptcustomerservice@cfo.pitt.edu. This work is being managed by Megan Fetsko, Pitt IT Enterprise Applications.
Posted May 18, 2026 - 12:26 EDT
This scheduled maintenance affected: Human Resources and Financial Systems (PantherExpress (Jaggaer)).