Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Jul 16, 2026 - 22:34 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 16, 2026 - 21:00 EDT
Scheduled
Pitt Digital will perform network infrastructure upgrades Thursday, July 16, from 9 p.m. until midnight. PittNet Wired and Wi-Fi networks and services that rely on them will be briefly impacted during the maintenance. No action is required by users.
• Internet Traffic Delays: There may be brief, intermittent delays in internet traffic on PittNet Wi-Fi and wired networks. These delays may temporarily affect loading times for external websites and streaming services. MyResNet will not be impacted.
• GlobalProtect VPN Connectivity: Users connected to GlobalProtect may be automatically disconnected and reconnected during the maintenance. New VPN connections may also be briefly delayed.
• Site-to-Site Connectivity: VPN connectivity between campus, the data center, and services including AWS, Oracle, and UPMC may experience short, intermittent disruptions.
Pitt Digital scheduled this window during low-traffic hours to limit impact on campus operations. We will monitor and post updates to https://status.pitt.edu if significant changes or delays occur.
This work is part of our network modernization initiative that has installed nearly 4,000 new Wi-Fi access points and upgraded wired network connections across the Pittsburgh campus. Learn more at https://digital.pitt.edu/wifi.
If this maintenance window conflicts with a critical activity in your area, or if you experience issues or have questions, please submit a ticket to the Technology Help Desk at https://digital.pitt.edu/helprequest or call 412-624-HELP (4357).
Posted Jul 14, 2026 - 17:44 EDT
This scheduled maintenance affected: Wired and Wi-Fi Networks (PittNet Wired Network, Eduroam, PittNet Wi-Fi, Pitt Guest Wi-Fi) and Network, Hosting, and Storage (PittNet VPN (GlobalProtect)).