Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 29, 2026 - 23:40 EDT
Scheduled
Salesforce Marketing Cloud will be unavailable between approximately 11:40 and 11:55 p.m. on Friday, May 29, while the vendor performs scheduled system maintenance.
All automated workflows and messaging activity will be queued while maintenance is in progress and will resume once it has been completed. In addition, Cloud Pages and some API services will not be available during the maintenance period.
Although not required, the vendor recommends pausing automations, sends, and related activities before maintenance begins.
Pitt Digital will closely monitor the upgrade in coordination with the vendor. If issues arise or the outage extends beyond the scheduled window, updates will be posted to https://status.pitt.edu.
Posted May 27, 2026 - 14:53 EDT
This scheduled maintenance affected: Administrative and Business Systems (Salesforce Marketing Cloud).