Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 19, 2025 - 22:00 EST
Scheduled
Pitt Worx will be unavailable from Fri., Dec. 19, at 10 p.m., until Sun., Dec. 21 at 7 p.m. ET while the vendor (Oracle) performs payroll maintenance and the HCM Solutions Team configures the Pitt Worx Learning which will be available on Monday, December 22. Please note that all employees within Pitt Worx will have access to Pitt Worx Learning. This is a phased rollout. In the current phase, we're migrating courses from Talent LMS into Pitt Worx Learning. The next phase will begin after the new year. Please see the additional details https://pitt.sharepoint.com/sites/human-resources/Pitt-Worx/Pitt%20Worx%20LMS/Pitt%20Worx%20Learning.aspx.
Those who need to submit timecards for the week of Dec. 14 - 20 should plan to do so before the outage period. As a reminder, timecards must be submitted and approved by the early deadline of Friday, Dec. 19.
This maintenance period was determined according to Oracle’s payroll legislative patches schedule and includes system updates to legislative functions for local, state, and federal tax changes for 2025. These functionalities have been tested and approved for migration by Payroll department users. The HCM Solutions LMS Project Team has configured and tested the Pitt Worx Learning functionality and has approved it for migration.
The HCM Solutions Team has completed checks to ensure that the system is ready for the updates. In the unlikely event of an issue, the HCM Solutions Team will closely collaborate with Oracle to determine the cause and resolve the issue. If the outage period is extended, updates will be provided at https://status.pitt.edu/.
Please contact the Technology Help Desk by calling +1-412-624-HELP if you experience any issues or have any questions regarding this maintenance. This effort is being led by John Scifo and Aleksandra Arsić, Pitt Digital’s managers of enterprise HCM applications.
For questions about using Pitt Worx and Talent Center, please submit an inquiry to the Office of Human Resources at https://hr.pitt.edu/contact-ohr.
Posted Dec 15, 2025 - 12:14 EST
This scheduled maintenance affected: Human Resources and Financial Systems (Pitt Worx).