Action May Be Required Following PittNet Wi-Fi Certificate Update

Incident Report for Pitt Digital Systems Status

Resolved

This incident has been resolved.
Posted Jun 29, 2026 - 11:37 EDT

Monitoring

As a reminder, PittNet Wi-Fi’s security certificate was recently renewed. Those experiencing certificate-related trouble connecting to PittNet Wi-Fi or GlobalProtect VPN can resolve the issue by doing one of the following:

• Accept the renewed certificate when prompted during connection. Search "Understanding Certificate Upgrades and Connecting to WIRELESS-PITTNET" at https://services.pitt.edu for step-by-step instructions.
• Forget PittNet Wi-Fi on your device and reconnect.

If you continue to experience issues, submit a ticket to the Technology Help Desk at (https://digital.pitt.edu/helprequest) or call +1-412-624-HELP (4357).
Posted Jun 22, 2026 - 11:52 EDT
This incident affected: Wired and Wi-Fi Networks (PittNet Wi-Fi) and Network, Hosting, and Storage (PittNet VPN (GlobalProtect)).