RESOLVED: Issue Affecting PittNet Wi-Fi Service on Pittsburgh Campus

Incident Report for Pitt IT Systems Status

Resolved

Monitoring confirms the issue has been fully resolved.
Posted Jul 17, 2025 - 16:29 EDT

Monitoring

Pitt Information Technology has resolved the issue that affected access to PittNet Wi-Fi, Eduroam, and Pitt Guest Wi-Fi services on the Pittsburgh campus earlier this morning. We continue to monitor all services closely and will post any additional updates to status.pitt.edu.

We are working with our vendors to identify the issue’s root cause and take steps to address it. We are committed to providing the best possible support to the University community and apologize for any disruptions caused by this outage.

For the latest updates on known issues and planned service maintenance periods, visit status.pitt.edu. Should you encounter any other issues using services provided by Pitt IT, please submit a ticket to the Technology Help Desk or call +1-412-624-HELP (4357).
Posted Jul 17, 2025 - 09:26 EDT

Investigating

Pitt Information Technology is aware of an issue affecting the ability of individuals on the Pittsburgh campus to connect to PittNet Wi-Fi, Eduroam, and Pitt Guest Wi-Fi services. MyResNet Wi-Fi and regional campuses are not affected.

Pitt IT is working with the vendor to resolve the issue and restore full service as quickly as possible. Updates will be posted to status.pitt.edu.
Posted Jul 17, 2025 - 08:23 EDT
This incident affected: Wired and Wi-Fi Networks (Eduroam, PittNet Wi-Fi, Pitt Guest Wi-Fi).