Vendor Issue Affecting Claude for Education Performance

Incident Report for Pitt Digital Systems Status

Resolved

The vendor has resolved the issue that affected Claude for Education earlier today and restored full service.
Posted Jun 23, 2026 - 13:21 EDT

Identified

Pitt Digital is aware of a vendor issue that is causing elevated error rates for some users of Claude for Education. The vendor is working to resolve the issue, which affects customers beyond the University of Pittsburgh. Updates will be posted to status.pitt.edu as more details become available.
Posted Jun 23, 2026 - 10:47 EDT
This incident affected: Generative AI Tools (Claude for Education).