Intermittent Vendor Issue Affecting Salesforce

Incident Report for Pitt Digital Systems Status

Resolved

The vendor has resolved their intermittent issue and restored full service. Pitt Digital continues to monitor Salesforce closely to ensure continued reliability and stability of the service.
Posted Sep 16, 2026 - 15:27 EDT

Identified

Pitt Digital is aware of an intermittent vendor issue that is affecting Salesforce. Individuals affected by the issue may be unable to access the service or may experience delays and slow performance.

The vendor has identified the cause of the issue — which affects customers beyond the University of Pittsburgh — and is working to fully resolve it. Pitt Digital will post updates to status.pitt.edu as more information becomes available.
Posted Sep 16, 2026 - 09:26 EDT
This incident affected: Administrative and Business Systems (Salesforce ERM/CRM, Salesforce Service Desk).