Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 22, 2025 - 00:00 EDT
Scheduled
Facilities Management identified a piece of deteriorating electrical equipment in Old Engineering Hall during an electrical inspection. As a safety precaution, Facilities Management will perform emergency maintenance on the equipment between midnight on Friday, March 21, and 4 a.m. on Saturday, March 22.
To accommodate this maintenance, Pitt Information Technology must take network service offline in some Pittsburgh campus buildings while power is interrupted. PittNet Wired and Wi-Fi network service (Wireless-PittNet, Eduroam, and Pitt Guest Wi-Fi) will be unavailable during the maintenance period. MyResNet Wi-Fi service will remain available.
The following buildings are affected:
• Allen Hall • Falk School • Fraternity Complex • Gardner Steel Conference Center • Irvis Hall • Nordenberg Hall • Old Engineering Hall • Panther Hall • Soldiers & Sailors • Space Research Coordination Center • Sutherland Hall • Thackeray Hall • Thaw Hall • University Club • University Hall • Van de Graaff Building
This emergency maintenance work will address the electrical issue until replacement equipment arrives. A second maintenance period to install the replacement part will be announced as soon as the date and time have been scheduled.
Facilities Management is announcing this maintenance period through their communication channels, and Pitt IT is collaborating with them to raise awareness through our channels. Pitt IT will be onsite to make certain all network connectivity is restored following the completion of the electrical maintenance. In the event that network service is interrupted beyond 4 a.m. on Saturday morning, updates will be posted to status.pitt.edu.
Please call the Technology Help Desk at +1-412-624-HELP (4357) if you experience any network issues after the maintenance period has been completed.
Posted Mar 20, 2025 - 16:51 EDT
This scheduled maintenance affected: Wired and Wi-Fi Networks (PittNet Wired Network, Eduroam, PittNet Wi-Fi, Pitt Guest Wi-Fi).