Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 18, 2025 - 21:00 EDT
Scheduled
PittNet wired and Wi-Fi service will be affected in several locations during brief network maintenance scheduled for this Friday, April 18, from 9–11 p.m. Each of the following areas will lose data connection for about 5 minutes at within the outage window:
• Parkvale Building (first floor) • Plum Boro Building (first floor) • Posvar Hall (second floor) • Scaife Hall (fifth floor) • The Assembly (5051 Centre Ave.) (sixth floor)
This maintenance is part of vendor-required best practices to ensure the continued security, stability, and reliability of older network hardware components. Pitt IT has completed checks to ensure that the hardware is ready for the maintenance and will be actively engaged with the vendor throughout the maintenance period.
Please call the Technology Help Desk at +1-412-624-HELP (4357) if you experience any issues or have questions regarding this maintenance. This effort is being led by Dan Mahaven, associate director, operations.
Posted Apr 17, 2025 - 16:07 EDT
This scheduled maintenance affected: Wired and Wi-Fi Networks (PittNet Wired Network, Eduroam, PittNet Wi-Fi, Pitt Guest Wi-Fi).