Comcast Issue Affecting PittNet Wi-Fi Service at Hampton Inn

Incident Report for Pitt Digital Systems Status

Resolved

Comcast has resolved their issue that affected PittNet Wi-Fi service at the Hampton Inn this evening. Full service has been restored. Pitt Digital continues to closely monitor affected services to ensure continued reliability and stability.
Posted Apr 13, 2026 - 19:54 EDT

Investigating

Comcast is experiencing an issue with their network hardware that is affecting PittNet Wi-Fi service for students living in the Hampton Inn. Pitt Digital is engaged with Comcast, who is working to resolve the issue and restore service as quickly as possible. PittNet Wi-Fi service remains available at all other campus locations. Updates will be posted to status.pitt.edu.
Posted Apr 13, 2026 - 18:42 EDT
This incident affected: Wired and Wi-Fi Networks (PittNet Wi-Fi).