Pitt Digital has resolved the issue that briefly affected the ability of students to release print jobs by swiping their Pitt ID card at PittPrint stations. Full service has been restored. We continue to closely monitor the service and will post any additional updates to status.pitt.edu.
Posted Apr 13, 2026 - 13:18 EDT
Investigating
Pitt Digital is aware of a issue that is affecting the ability of students to release print jobs by swiping their Pitt ID card at PittPrint stations. As a workaround, students can release print jobs by downloading and installing the Pharos app from the App Store or Google Play.
Pitt Digital is working with the vendor to resolve the issue and restore full service as quicky as possible. This issue does not affect printers used by University departments. Updates will be posted to status.pitt.edu as more information becomes available.
Posted Apr 13, 2026 - 13:08 EDT
This incident affected: Printing, Desktop and Mobile Computing, and Software (PittPrint).