Azure Compute Services, Data Storage, and Virtual Labs Impacted by Network Circuit Issue

Incident Report for Pitt IT Systems Status

Resolved

DQE Communications has resolved the issue and restored full service.
Posted May 29, 2025 - 06:44 EDT

Identified

Pitt Information Technology is aware of a network circuit issue that affects access to Azure via PittNet Wired and Wi-Fi connections. Impacted services include Azure Compute Services, Azure Data Storage, and Computing Labs/Virtual Lab.

DQE Communications is actively working to resolve the issue and has advised that full service restoration may take until 6 a.m. Updates will be posted to status.pitt.edu as new information becomes available.

Please call the Technology Help Desk at +1-412-624-HELP (4357) if you have any questions related to this announcement.
Posted May 28, 2025 - 21:32 EDT
This incident affected: Printing, Desktop and Mobile Computing, and Software (Computing Labs / Virtual Lab) and Network, Hosting, and Storage (Enterprise Data Storage).