Intermittent Microsoft Issue Affecting Pitt Email Access for Some Individuals

Incident Report for Pitt IT Systems Status

Resolved

Microsoft has resolved the intermittent issue that affected Pitt Email earlier today. Full service has been restored. Pitt IT continues to monitor the service closely and will post any additional updates to status.pitt.edu. If you continue to experience issues with Pitt Email, please report them to the Technology Help Desk at +1-412-624-HELP (4357).
Posted Jul 10, 2025 - 16:03 EDT

Update

Update: Microsoft has identified the cause of the intermittent issue affecting access to Pitt Email for a limited number of individuals at the University. Microsoft has taken steps to resolve the issue and expects normal service to be restored for all affected customers by approximately 2:30 p.m. EDT. Pitt IT continues to closely monitor the service and will post additional updates to status.pitt.edu.
Posted Jul 10, 2025 - 13:50 EDT

Identified

Pitt Information Technology is aware of an intermittent Microsoft issue that is affecting the ability of some individuals to access email through the Outlook web client, Outlook desktop app, and Outlook mobile app. The issue is affecting Microsoft customers beyond the University of Pittsburgh.

Microsoft is working to resolve the issue and restore full service as quickly as possible. Updates will be posted to status.pitt.edu as more information becomes available.
Posted Jul 10, 2025 - 11:04 EDT
This incident affected: Email and Calendar (Microsoft Outlook).