Resolved: Issue Briefly Affected Access to Salesforce Services

Incident Report for Pitt Digital Systems Status

Resolved

Pitt Digital is aware of a certificate issue that briefly affected the ability of individuals to access Salesforce services at Pitt this morning, including Salesforce ERM/CRM, Salesforce Marketing Cloud, Salesforce Recruiting, and Salesforce Service Desk.

Pitt Digital has resolved the issue and restored full service. We continue to closely monitor affected services and will post any additional updates to status.pitt.edu. If you experience issues accessing any Salesforce services at Pitt, please report them to the Technology Help Desk at +1-412-624-HELP (4357).
Posted Oct 16, 2025 - 09:13 EDT
This incident affected: Administrative and Business Systems (Salesforce ERM/CRM, Salesforce Marketing Cloud, Salesforce Recruiting, Salesforce Service Desk).