Perceptive Content remains available and no further maintenance periods are scheduled at this time.
Posted May 18, 2026 - 16:17 EDT
Update
Web client access to Document Management (Perceptive Content) has been restored. The maintenance window previously scheduled from 5 to 7 p.m. today has been cancelled, and no further action is required. This update is also reflected on status.pitt.edu.
Please submit a ticket to the Technology Help Desk or call +1-412-624-HELP (4357) if you have questions.
Posted May 18, 2026 - 16:16 EDT
Scheduled
As we continue to restore full access to Document Management (Perceptive Content) after this weekend's upgrade, please be aware that the system will be unavailable between 5 and 7 p.m. today to accommodate additional server maintenance. You may resume work in the system after 7 p.m.
Thank you for your continued patience. Please submit a ticket to the Technology Help Desk or call +1-412-624-HELP (4357) if you have questions.
Posted May 18, 2026 - 14:02 EDT
This scheduled maintenance affects: Administrative and Business Systems (Perceptive Content).