Vendor Issue Affecting DocuSign

Incident Report for Pitt Digital Systems Status

Resolved

Pitt Digital has worked with the vendor to resolve the issue and restore full service. We continue to closely monitor the service to ensure stability and will post any additional updates to status.pitt.edu.
Posted Feb 06, 2026 - 17:53 EST

Investigating

Pitt Digital is aware of a vendor issue that appears to be affecting some functionality within DocuSign. Pitt Digital is working with our vendor partner to confirm the issue and its impact on the Pitt community and take steps to resolve it. Updates will be posted to status.pitt.edu as more details become available.
Posted Feb 06, 2026 - 17:02 EST
This incident affected: Administrative and Business Systems (DocuSign).