Issue Affecting Access to Short URLs

Incident Report for Pitt Digital Systems Status

Resolved

Pitt Digital has resolved the issue that affected access to website addresses shortened through the pi.tt URL shortener. Full service has been restored. We continue to monitor the service closely to ensure continued stability and reliability.
Posted Jun 25, 2026 - 18:33 EDT

Investigating

Pitt Digital is aware of an issue that is affecting access to website addresses shortened through the pi.tt URL shortener. Individuals affected by the issue may encounter an error message or be redirected to the main www.pitt.edu website.

Pitt Digital is aware of the issue and working to restore full service as quickly as possible. Updates will be posted to status.pitt.edu as more information becomes available.
Posted Jun 25, 2026 - 17:16 EDT