Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 23, 2026 - 22:00 EST
Scheduled
Pitt Worx will be unavailable from Friday, Jan. 23, at 10 p.m., until Saturday, Jan. 24, at 7 p.m. ET while the vendor (Oracle) performs time and labor maintenance. Those who need to submit timecards for the week of Jan. 18-24 should plan to do so before or after the outage period. As a reminder, timecards must be submitted and approved by the deadline of noon on Monday, Jan. 26.
This maintenance period was determined according to Oracle’s Exception Maintenance schedule and includes system updates to specific modules in Time and Labor. These functionalities have been tested and approved for migration by Time and Labor department users.
The HCM Solutions Team has completed checks to ensure that the system is ready for the updates. In the unlikely event of an issue, the HCM Solutions Team will closely collaborate with Oracle to determine the cause and resolve the issue. If the outage period is extended, updates will be provided at https://status.pitt.edu/.
Please contact the Technology Help Desk by calling +1-412-624-HELP if you experience any issues or have any questions regarding this maintenance. This effort is being led by John Scifo, Pitt Digital’s manager of enterprise HCM applications.
For questions about using Pitt Worx and Talent Center, please submit an inquiry to the Office of Human Resources at https://hr.pitt.edu/contact-ohr.
Posted Jan 22, 2026 - 08:37 EST
This scheduled maintenance affected: Human Resources and Financial Systems (Pitt Worx).