Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 16, 2025 - 22:01 EDT
Scheduled
PittNet, the University’s wired and Wi-Fi networks, may experience brief outages of up to 45 minutes this weekend, starting Friday, May 16, at 9 p.m. until Saturday, May 17, at 2 a.m.
The following buildings are affected during this week’s maintenance: - Benedum Hall (12th floor) - Carillo Steam Plant - Cathedral of Learning (ground floor) - Chilled Water Plant - Cost Sports Center (North and South) - Forbes Tower (7th floor) - Fitzgerald Field House - Holland Hall (3rd floor) - Oak Hill - Petersen Sports Complex - Posvar Hall (3rd floor) - Tower View Garage - Trees Field (Dome) - Trees Hall
The maintenance period was scheduled by Pitt IT in consultation with Athletics and the Office of Public Safety’s Integrated Security Department (ISD).
This ongoing project focuses on improving the security, performance, and reliability of the network that provides connectivity to the internet as well as to resources inside and outside of PittNet.
PittIT has completed checks to ensure that systems are ready for the upgrades and will be actively engaged with the vendor throughout the maintenance periods. In the unlikely event that an issue or problem arises, the vendor will revert to its original network configuration and Pitt IT will post an update to status.pitt.edu.
Please call the Technology Help Desk at +1-412-624-HELP (4357) if you experience any issues or have questions regarding this maintenance. This effort is being led by Lou Passarello, Pitt IT’s director of operations.
Posted May 13, 2025 - 11:18 EDT
This scheduled maintenance affected: Wired and Wi-Fi Networks (PittNet Wired Network, Eduroam, PittNet Wi-Fi, Pitt Guest Wi-Fi).