Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 10, 2024 - 23:59 EDT
Scheduled
TeamDynamix (TDX), the University’s IT Service Management platform, will be unavailable while the vendor performs an upgrade starting on Friday, May 10, at 11:59 p.m., through Saturday, May 11, at 4 a.m.
TDX ticketing used by the Technology Help Desk and other departmental help desks will be offline. However, the Technology Help Desk will remain available via phone throughout the maintenance period. In addition, the IT Services Portal (services.pitt.edu), Knowledge Base, and TDX project management will be unavailable during the upgrade.
This upgrade is required by the vendor to help ensure high levels of availability, secure work environments, and continued reliability and stability of critical systems. There will be no notable changes to the user interface. However, there will be some feature enhancements for TDX analysts, including personalized signatures and a new print view for Knowledge Base articles.
Pitt IT has completed checks to ensure that TDX is ready for the update and will monitor progress during the maintenance period. In the unlikely event that an issue or problem arises, the vendor will revert the system to its previous configuration and we will post an update to status.pitt.edu.
Please contact the Technology Help Desk at +1-412-624-HELP (4357) if you have any questions regarding this upgrade. This effort is being led by Kathy Lyons, Pitt IT’s associate director of continual service improvement.
Posted May 08, 2024 - 08:52 EDT
This scheduled maintenance affected: Administrative and Business Systems (TeamDynamix).