Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 18, 2025 - 19:00 EST
Scheduled
Pitt Digital will conduct scheduled network maintenance on December 18. During this period, the buildings listed below will experience brief interruptions to PittNet Wi-Fi and wired network services.
Thursday, Dec. 18, from 7 p.m. until Friday, Dec. 19, at 1 a.m., affecting the following locations: • Alumni Hall • Bakery Square • Bellfield Hall • Clapp Hall • Crawford Hall • Heiber Building • Langley Hall • Life Science Annex • Music Building • Ruskin Hall • Sterling Building • The Offices at Baum • Thomas Boulevard
Network connectivity to cloud providers, websites, or other internet resources from campus or the Data Center — as well as accessing campus resources remotely from GlobalProtect or other external services — may be affected in the above locations.
Pitt Digital will be monitoring the process, and in the event of any significant changes or delays, updates will be posted to status.pitt.edu. This maintenance is part of our efforts to modernize the campus network and ensure continued security, stability, and reliability. These maintenance periods were scheduled during winter recess and before the start of spring term to minimize impact on the University community.
Please submit a ticket to the Technology Help Desk at https://digital.pitt.edu or call +1-412-624-HELP (4357) if you experience any issues or have questions related to these maintenance periods. This effort is being led by Dan Mahaven, Pitt Digital Operations.
Posted Dec 15, 2025 - 11:18 EST
This scheduled maintenance affected: Wired and Wi-Fi Networks (PittNet Wired Network, Eduroam, PittNet Wi-Fi, Pitt Guest Wi-Fi).