Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 02, 2025 - 15:00 EDT
Scheduled
PantherExpress will be temporarily unavailable during scheduled maintenance Friday, May 2 from 3 p.m. to noon on Sunday, May 4. Please complete transactions, save all work, and exit the system before 3 p.m. on Friday. Any unsaved work will be lost when the system goes offline.
During this upgrade, user records will be updated to reflect the most current information from Oracle and will help to ensure consistency across University systems. As a result, users may notice updates to their PantherExpress profile, including name, address, and phone number.
The PantherExpress Team will monitor services throughout the upgrade. Should any unexpected issue occur, Financial Operations has a contingency plan in place. In the unlikely event of a prolonged service outage, updates will be provided at http://status.pitt.edu.
If you have questions or concerns about PantherExpress, please contact Purchase, Pay & Travel Customer Service at https://www.ppt.pitt.edu/help-training/contact-us. This effort is being managed by Bob Hestor, Pitt IT Enterprise Applications.
Posted Apr 29, 2025 - 14:45 EDT
This scheduled maintenance affected: Human Resources and Financial Systems (PantherExpress (Jaggaer)).