Some T-Mobile Customers Receiving Scam Warning When Calling Help Desk

Incident Report for Pitt Digital Systems Status

Investigating

Pitt Digital is aware that some individuals who use T-Mobile as their cellular network provider are receiving a warning message when dialing the University’s Technology Help Desk at +1 412 624-HELP (4357). The message advises callers that the number they are calling may be associated with a scam.

Pitt Digital is working with our vendor partners to resolve the issue. As a temporary workaround, T-Mobile customers who receive the message can simply stay on the line for a few additional seconds to be connected directly to the Technology Help Desk.

Updates will be posted to status.pitt.edu as more information becomes available.
Posted Dec 23, 2025 - 15:12 EST
This incident affects: IT Support Services (Technology Help Desk).