Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 27, 2025 - 21:00 EDT
Scheduled
Pitt Information Technology will perform overnight network maintenance beginning on Friday, June 27, at 9 p.m., through Saturday, June 28, at 3 a.m. Holland Hall will experience a brief outage to the PittNet Wi-Fi and wired networks during the maintenance.
Network connectivity to cloud providers, websites, or other internet resources from campus or the datacenter, or accessing campus resources remotely from GlobalProtect or other external services may be affected in this location.
Pitt IT will be monitoring the process, and in the event of any significant changes or delays, updates will be posted to https://status.pitt.edu/. This maintenance is part of our efforts to ensure continued security, stability, and reliability of the network.
Please submit a ticket to the Technology Help Desk at https://technology.pitt.edu/helprequest or call +1-412-624-HELP (4357) if you experience any issues or have questions related to this maintenance. This effort is being led by Dan Mahaven, Pitt IT Operations.
Posted Jun 26, 2025 - 17:04 EDT
This scheduled maintenance affected: Wired and Wi-Fi Networks (PittNet Wired Network, Eduroam, PittNet Wi-Fi, Pitt Guest Wi-Fi).