Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 29, 2025 - 21:00 EDT
Scheduled
DQE Communications is performing required network maintenance between 9 p.m. tonight and 5 a.m. on Friday, May 30. Access from the University’s network to the following services will be unavailable during the maintenance period: Azure Compute Services, Azure Data Storage, Computing Labs/Virtual Lab, and resources on the Internet2 research network. This scheduled DQE maintenance impacts customers beyond the University of Pittsburgh and is a City of Pittsburgh requirement.
Pitt IT will monitor services throughout the maintenance period and post any additional updates to status.pitt.edu. Please call the Technology Help Desk at +1-412-624-HELP (4357) if you experience any issues accessing Microsoft Azure services after maintenance is complete.
Posted May 29, 2025 - 12:12 EDT
This scheduled maintenance affected: Printing, Desktop and Mobile Computing, and Software (Computing Labs / Virtual Lab) and Network, Hosting, and Storage (Enterprise Data Storage).