Microsoft Issue Affecting Enterprise Virtual Desktop Hosting and Some Other Azure Services

Incident Report for Pitt Digital Systems Status

Resolved

Microsoft confirms that the issue has been resolved and full service has been restored. Pitt Digital continues to monitor the service and will post any additional updates to status.pitt.edu. Please call the Technology Help Desk at +1-412-624-HELP (4357) if you encounter any issues using Microsoft Azure services.
Posted Sep 10, 2025 - 17:32 EDT

Monitoring

Update: Microsoft has taken steps to mitigate their issue. Pitt Digital’s monitoring indicates affected services at the University have been restored. Pitt Digital continues to closely monitor the service and will post additional updates to status.pitt.edu. If you continue to experience issues accessing Azure services, please contact the Technology Help Desk at +1-412-624-HELP (4357).
Posted Sep 10, 2025 - 12:01 EDT

Identified

Pitt Digital is aware of a Microsoft issue that is affecting the ability to create, start, stop, and manage new virtual machines on some Azure cloud services. The Enterprise Virtual Desktop Hosting and Virtual Computing Lab services are not impacted by the issue at this time.

Microsoft is working to resolve the issue as quickly as possible, which affects customers beyond the University of Pittsburgh. Updates will be posted to status.pitt.edu as they become available.
Posted Sep 10, 2025 - 10:09 EDT
This incident affected: Printing, Desktop and Mobile Computing, and Software (Enterprise Virtual Desktop Hosting).