Issue Affecting Microsoft Teams Calling

Incident Report for Pitt Digital Systems Status

Resolved

This incident has been resolved.
Posted Jul 03, 2026 - 00:25 EDT

Monitoring

Calling has been restored following a corrected certificate issue on our service provider's end. Pitt Digital will continue monitoring to confirm stability before marking this incident resolved.
Posted Jul 02, 2026 - 12:44 EDT

Update

Pitt Digital continues to investigate. Calls to and from the Technology Help Desk are also affected. To request support, submit a ticket at https://services.pitt.edu using "Request Help."
Posted Jul 02, 2026 - 11:15 EDT

Investigating

Pitt Digital is investigating an issue affecting inbound and outbound calls made through Microsoft Teams. If your University phone number is tied to Teams, you may be unable to place or receive calls at this time.

In an emergency: Use a mobile phone or a line not tied to Teams to reach Pitt Police at 412-624-2121. Calls placed from a Teams-connected phone may not go through.

• Bradford campus: 814-368-3211
• Greensburg campus: 724-836-9865
• Johnstown campus: 814-269-7005
• Pittsburgh campus: 412-624-2121
• Titusville campus: 814-827-4488

Dial 911 for any off-campus emergencies.

Pitt Digital is working to identify the cause and restore full calling as quickly as possible. Updates will be posted to status.pitt.edu.
Posted Jul 02, 2026 - 10:16 EDT
This incident affected: Microsoft Teams and Communication and Collaboration (Voice and Data Services (Telephony)).