Commercial Power Provider Outage Cause of Bradford Campus Network Service Interruption

Incident Report for Pitt IT Systems Status

Resolved

The commercial service provider has restored power and network service is once again available.
Posted Mar 16, 2025 - 19:48 EDT

Identified

A commercial power provider serving the University of Pittsburgh at Bradford campus is experiencing an issue that is disrupting power to the campus, affecting a wide variety of services including PittNet Wired and Wi-Fi. The provider is working to resolve the issue and restore power as quickly as possible. Once power has been restored to the campus, affected services like PittNet Wired and Wi-Fi will be back online. We will post additional updates to status.pitt.edu as more information becomes available.
Posted Mar 16, 2025 - 12:17 EDT
This incident affected: Wired and Wi-Fi Networks (MyResNet (Apogee Residential Wi-Fi), PittNet Wired Network, PittNet Wi-Fi).