Issue Affecting PittNet Wired and Wi-Fi Service at Allen Hall and Thackeray Hall

Incident Report for Pitt Digital Systems Status

Resolved

Pitt Digital has resolved the issue that affected PittNet Wired and Wi-Fi service at Allen Hall and Thackeray Hall earlier today. Full service has been restored. We continue to closely monitor affected services to ensure continued reliability and stability.
Posted Mar 10, 2026 - 16:44 EDT

Update

Pitt Digital continues working to resolve the issue affecting PittNet Wired and Wi-Fi service at Allen Hall and Thackeray Hall. As more updates become available, they will be posted to status.pitt.edu.
Posted Mar 10, 2026 - 14:48 EDT

Update

Pitt Digital continues working to resolve the issue affecting PittNet Wired and Wi-Fi service at Allen Hall and Thackeray Hall. Additional updates will be posted to status.pitt.edu.
Posted Mar 10, 2026 - 13:39 EDT

Investigating

Pitt Digital is aware of an issue that is affecting PittNet Wired and Wi-Fi service at Allen Hall and Thackeray Hall on the Pittsburgh campus. We are working to resolve the issue and restore full service as quickly as possible. Updates will be posted to status.pitt.edu.
Posted Mar 10, 2026 - 12:40 EDT
This incident affected: Wired and Wi-Fi Networks (PittNet Wired Network, PittNet Wi-Fi).