RESOLVED: Intermittent Issue Affecting Campaign Monitor Access

Incident Report for Pitt Digital Systems Status

Resolved

Monitoring confirms the issue has been resolved.
Posted Dec 02, 2025 - 17:29 EST

Monitoring

Pitt Digital has taken steps to resolve the issue and restore full service. We continue to monitor the service to ensure continued stability and reliability. Additional updates will be posted to status.pitt.edu as needed.
Posted Dec 02, 2025 - 11:29 EST

Identified

Pitt Digital continues working to fully resolve the intermittent issue. Additional updates will be posted to status.pitt.edu.
Posted Dec 02, 2025 - 10:04 EST

Investigating

Pitt Digital is aware of an intermittent issue that is affecting the ability of some individuals to access Campaign Monitor, a service used by some departments to send email communications to their list of subscribers. Individuals affected by the issue may not be able to proceed past the loading screen when attempting to log in.

Pitt Digital is working with the vendor to resolve the issue and restore full service as quickly as possible. Updates will be posted to status.pitt.edu.
Posted Dec 01, 2025 - 16:49 EST
This incident affected: Communication and Collaboration (Campaign Monitor).