Resolved: Brief Interruption to PeopleSoft Student Information System

Incident Report for Pitt IT Systems Status

Resolved

Monitoring confirms the issue remains resolved.
Posted May 02, 2025 - 15:44 EDT

Investigating

Pitt Information Technology is aware of a vendor issue that briefly affected access to the PeopleSoft Student Information System between approximately 10:50 and 11:10 a.m. this morning. Pitt IT worked with the vendor to resolve the issue and restore full service.

We are working with the vendor to identify the issue’s root cause and take steps to address it. We continue to closely monitor the service and will post additional updates to status.pitt.edu.
Posted May 02, 2025 - 11:29 EDT
This incident affected: PeopleSoft/HighPoint CX (Student Information System).