Monitoring confirms the issue has been fully resolved.
Posted Sep 17, 2026 - 16:04 EDT
Monitoring
Pitt Digital has taken steps to resolve the issue affecting Perceptive Content and has restored full service. We continue to monitor the service closely to ensure continued reliability and stability.
Posted Sep 17, 2026 - 10:45 EDT
Investigating
Pitt Digital is aware of an issue that is causing slow performance for users of Perceptive Content, a service that enables the scanning, archiving, and retrieving of documents. Affected individuals may see slow processing or time-outs for uploads or requests.
Pitt Digital is working with the vendor to resolve the issue as quickly as possible. Perceptive Content will be unavailable for up to half an hour beginning at 9:30 a.m. while a fix is implemented. Updates will be posted to status.pitt.edu as more information becomes available.
Posted Sep 17, 2026 - 09:13 EDT
This incident affected: Administrative and Business Systems (Perceptive Content).