Service Provider Issue Affecting Concur Travel and Expense Management

Incident Report for Pitt IT Systems Status

Resolved

The service provider has taken steps to resolve the issue and restore full service. We continue to monitor the service and will post additional updates as needed.
Posted Sep 19, 2023 - 08:38 EDT

Investigating

The Office of the Chief Financial Officer and Pitt Information Technology are aware of a service provider issue that is affecting travel request submissions in the Concur Travel & Expense System.

The service provider is aware of the issue and working to restore full service as quickly as possible. Updates will be posted to status.pitt.edu as more information becomes available.

Please contact the 24/7 IT Help Desk at +1-412-624-HELP if you have any questions regarding this announcement.
Posted Sep 18, 2023 - 14:59 EDT
This incident affected: Human Resources and Financial Systems (Concur Travel & Expense).