Intermittent Issue Affects Some Duo MFA Voice and Text Notifications
Incident Report for Pitt IT Systems Status
Resolved
Duo has confirmed that all authentication services have returned to full service.
Posted Feb 23, 2024 - 07:47 EST
Identified
Pitt Information Technology is aware of an intermittent service provider issue that is affecting some Duo multifactor authentication notifications that are sent via text message (SMS) or telephone (Voice over Internet Protocol).

Affected individuals may experience issues using the “Send Me a Push” or “Call Me” options when logging in to University services through Pitt Passport.

Duo is working closely with telephony providers and has taken steps to address the problem and improve service, but it has not yet fully resolved the issue. Pitt IT is working with Duo and will post additional updates to status.pitt.edu. As a workaround, individuals who experience the issue with Duo MFA can still authenticate by opening the Duo app and tapping the key icon to generate a passcode.

If you have questions or encounter issues using Duo multifactor authentication, please contact the Technology Help Desk at +1 412 624-HELP (4357).
Posted Feb 22, 2024 - 07:40 EST
This incident affected: Pitt Passport (Multifactor Authentication (Duo)).