Vendor Issue Affecting Image Links in Salesforce Marketing Cloud Emails

Incident Report for Pitt Digital Systems Status

Resolved

The vendor has resolved their issue and restored full service. Pitt Digital continues to closely monitor services and will post any additional updates to status.pitt.edu.
Posted Oct 01, 2025 - 18:36 EDT

Update

The vendor continues working to resolve the issue and restore full service. Additional updates will be posted to status.pitt.edu
Posted Oct 01, 2025 - 17:52 EDT

Identified

Pitt Digital is aware of a vendor issue that is causing broken image links to display in email messages sent through Salesforce Marketing Cloud. Core Marketing Cloud functionality is unaffected by this issue.

Salesforce is working as quickly as possible to resolve the issue, which affects customers beyond the University of Pittsburgh. Updates will be posted to status.pitt.edu as more information becomes available. No other Salesforce-related University services are affected by this issue.
Posted Oct 01, 2025 - 15:39 EDT
This incident affected: Administrative and Business Systems (Salesforce Marketing Cloud).