Vendor Issue Affecting Concur Travel & Expense Service

Incident Report for Pitt IT Systems Status

Resolved

The vendor has resolved the issue affecting Concur Travel & Expense and restored full service. Pitt IT continues to closely monitor the service and will post any additional updates to status.pitt.edu as needed.
Posted Jul 10, 2025 - 14:08 EDT

Investigating

Pitt Information Technology is aware of a vendor issue that is affecting the Concur Travel & Expense service. The issue affects customers beyond the University of Pittsburgh.

The vendor is aware of the issue and working to restore full service as quickly as possible. Updates will be posted to status.pitt.edu as more information becomes available.
Posted Jul 10, 2025 - 11:22 EDT
This incident affected: Human Resources and Financial Systems (Concur Travel & Expense).