Monitoring confirms the issue has been fully resolved.
Posted Nov 07, 2025 - 15:04 EST
Monitoring
Pitt Digital has taken steps to mitigate the Perceptive Content issue and restore service. We are currently monitoring the service to ensure the issue has been fully resolved. Additional updates will be posted to status.pitt.edu.
Posted Nov 07, 2025 - 14:34 EST
Investigating
Pitt Digital is aware of an issue that is causing slow performance for users of Perceptive Content, a service that enables the scanning, archiving, and retrieving of documents. Affected individuals may see slow processing or time-outs for uploads and requests.
Pitt Digital is working to resolve the issue as quickly as possible. Updates will be posted to status.pitt.edu as more information becomes available.
Posted Nov 07, 2025 - 13:15 EST
This incident affected: Administrative and Business Systems (Perceptive Content).