Vendor Issue Affecting Access to Online Software Store Through PantherExpress

Incident Report for Pitt Digital Systems Status

Resolved

The vendor has resolved their issue that affected access to the Online Software Store via PantherExpress earlier today. Full service has been restored.
Posted Jan 22, 2026 - 13:22 EST

Investigating

Pitt Digital is aware of a vendor issue that is affecting the ability of purchasers to access the Online Software Store through PantherExpress.

Pitt Digital is working with the vendor to resolve the issue and restore full service as quickly as possible. Updates will be posted to status.pitt.edu as more information becomes available.
Posted Jan 22, 2026 - 11:43 EST
This incident affected: Human Resources and Financial Systems (PantherExpress (Jaggaer)).