AWS Issue Affecting Canvas, Tableau, and Some Other University Services

Incident Report for Pitt Digital Systems Status

Resolved

Amazon Web Services has resolved its issue that affected access to Canvas, Panopto, Qualtrics, Tableau, and other University services today. AWS is working to identify the issue’s root cause and take steps to address it. Pitt Digital continues to closely monitor affected services and will post any additional updates to status.pitt.edu.
Posted Oct 20, 2025 - 19:57 EDT

Update

AWS continues working to resolve the issue and restore service. Pitt Digital will continue to post updates to status.pitt.edu as more information becomes available.
Posted Oct 20, 2025 - 16:57 EDT

Update

AWS's mitigation efforts continue. PantherExpress access has now been restored, but access to Canvas and other services remains affected. Pitt Digital will continue to post updates to status.pitt.edu as details become available.
Posted Oct 20, 2025 - 14:59 EDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 13:27 EDT

Update

AWS is still working to fully resolve the issue and restore service. Please note that access to PantherExpress may also be intermittently affected by this issue.
Posted Oct 20, 2025 - 13:20 EDT

Update

AWS continues working to resolve the issue and restore service. Pitt Digital will continue to post updates to status.pitt.edu as more information becomes available.
Posted Oct 20, 2025 - 12:03 EDT

Update

Pitt Video (Panopto) is also affected by this issue. AWS continues working to resolve the issue and restore full service.
Posted Oct 20, 2025 - 10:43 EDT

Investigating

Amazon Web Services is experiencing issues affecting access to some University services, including Canvas, Tableau, Panopto, Qualtrics, Amazon Connect (used for call centers including the School of Dental Medicine and Athletics), and AWS storage services. The Technology Help Desk is not affected by this issue.

AWS is working to resolve the issue, which affects customers beyond the University of Pittsburgh. Updates will be posted to status.pitt.edu as more information becomes available.
Posted Oct 20, 2025 - 10:11 EDT
This incident affected: Canvas (Learning Management System), Human Resources and Financial Systems (PantherExpress (Jaggaer)), Academic Technologies (Pitt Video (Panopto), Qualtrics Online Survey System), and Data, Reporting, and Analytics (Tableau).