Issue Affecting Concur Service

Incident Report for Pitt IT Systems Status

Resolved

The issue affecting Concur has been resolved and full service restored.
Posted Jul 08, 2025 - 07:31 EDT

Monitoring

The service has returned to normal operating levels, and the vendor is monitoring performance to verify system stability.
Posted Jul 07, 2025 - 16:47 EDT

Investigating

Pitt Information Technology is aware of an issue that is affecting access for some users to the Concur Travel & Expense System. The service provider is aware of the issue and working to restore full service as quickly as possible. Updates will be posted to status.pitt.edu as more information becomes available.
Posted Jul 07, 2025 - 11:46 EDT
This incident affected: Human Resources and Financial Systems (Concur Travel & Expense).