RESOLVED: Vendor Issue Affecting Inbound and Outbound Calls to University Phone Numbers

Incident Report for Pitt IT Systems Status

Resolved

Monitoring confirms the issue has been resolved.
Posted Jun 06, 2025 - 14:21 EDT

Monitoring

Pitt Information Technology's vendor partner, Zito, has resolved their issue that affected the ability of University phone numbers to receive and place phone calls. We are working with Zito to identify the issue’s root cause and take steps to address it.

We are committed to providing the best possible support to the University community and apologize for any disruptions caused by this outage.

For the latest updates on known issues and planned service maintenance periods, visit status.pitt.edu. Should you encounter any other issues using services provided by Pitt IT, please submit a ticket to the Technology Help Desk or call +1-412-624-HELP (4357).
Posted Jun 06, 2025 - 12:44 EDT

Update

Individuals who are unable to reach the Pitt Police phone number (412-624-2121) should call 911 in the event of an emergency. The vendor, Zito, continues working to resolve the issue, which affects customers beyond the University of Pittsburgh.
Posted Jun 06, 2025 - 12:04 EDT

Investigating

Pitt Information Technology is aware of a vendor issue that is affecting the ability of University phone numbers to receive and place phone calls. Individuals receive a busy signal when attempting calls.

Pitt IT is working with the vendor to resolve the issue and restore full service. Updates will be posted to status.pitt.edu as more details become available.
Posted Jun 06, 2025 - 11:17 EDT
This incident affected: Communication and Collaboration (Voice and Data Services (Telephony)).