Issue Affecting PittNet Wired and Wi-Fi Service at Old Engineering Hall

Incident Report for Pitt Digital Systems Status

Resolved

Pitt Digital has resolved the issue that affected Old Engineering Hall earlier today. Full service has been restored.
Posted Mar 08, 2026 - 14:06 EDT

Update

We continue working with our vendor partner to resolve the issue. Updates will be posted to status.pitt.edu as more information becomes available.
Posted Mar 08, 2026 - 12:11 EDT

Update

Pitt Digital continues working with our vendor partner to resolve the issue and restore full service.
Posted Mar 08, 2026 - 10:57 EDT

Investigating

Pitt Digital is aware of an issue that is affecting PittNet Wired and Wi-Fi service at Old Engineering Hall on the Pittsburgh campus. We are working with our vendor partners to resolve the issue and restore full service as quickly as possible. Updates will be posted to status.pitt.edu.
Posted Mar 08, 2026 - 09:45 EDT
This incident affected: Wired and Wi-Fi Networks (PittNet Wi-Fi, Pitt Guest Wi-Fi).