RESOLVED: Intermittent Vendor Issue Causing Slow TeamDynamix Performance

Incident Report for Pitt Digital Systems Status

Resolved

Monitoring confirms the issue has been resolved.
Posted Nov 13, 2025 - 08:37 EST

Monitoring

The vendor has resolved their issue and restored full service to all affected TDX services. Pitt Digital continues to monitor services closely and will post any additional updates to status.pitt.edu.
Posted Nov 12, 2025 - 14:40 EST

Investigating

Pitt Digital is aware of an intermittent vendor issue that is causing slow performance for users of TeamDynamix (TDX). This issue may affect TDX ticketing, project portfolio management, the Knowledge Base, and the service catalog (services.pitt.edu).

The vendor is working to resolve the issue, which affects customers beyond the University of Pittsburgh. Pitt Digital will post updates to status.pitt.edu as more information becomes available.
Posted Nov 12, 2025 - 12:58 EST
This incident affected: Administrative and Business Systems (TeamDynamix).