Vendor Issue Affecting Access to Online Cybersecurity Training

Incident Report for Pitt Digital Systems Status

Resolved

The vendor has resolved their issue and restored access to online Security Awareness Training. Pitt Digital continues to closely monitor the affected service and will post additional updates to status.pitt.edu as needed.
Posted Oct 14, 2025 - 15:22 EDT

Investigating

Pitt Digital is aware of a vendor issue that is affecting access to the KnowBe4 online cybersecurity training modules used by students, faculty, and staff.

KnowBe4 is working as quickly as possible to resolve the issue and restore access. Updates will be posted to status.pitt.edu as more information becomes available.
Posted Oct 14, 2025 - 11:28 EDT
This incident affected: Accounts, Access, and Information Security (Security Awareness Training (KnowBe4)).