Issue Affecting PittNet Service in Holland Hall, Panther Central, University Store on Fifth

Incident Report for Pitt Digital Systems Status

Resolved

The issue that affected PittNet wired and Wi-Fi service to Holland Hall, Panther Central, and the University Store on Fifth has been resolved. Full service has been restored. Pitt Digital continues to closely monitor affected services to ensure continued reliability and stability.
Posted Feb 23, 2026 - 09:34 EST

Investigating

Pitt Digital is aware of an issue that is affecting PittNet Wi-Fi and wired service to Holland Hall, Panther Central, and the University Store on Fifth. We are working with our vendor partners to resolve the issue and restore full service as quickly as possible. Updates will be posted to status.pitt.edu.
Posted Feb 23, 2026 - 09:19 EST
This incident affected: Wired and Wi-Fi Networks (PittNet Wired Network, PittNet Wi-Fi).