Workaround for Issue Affecting Access to Faculty Information System (Elements)
Incident Report for University of Pittsburgh
Resolved
The issue that affected access to the Faculty Information System (Elements) has been resolved and full service has been restored.
Posted Feb 17, 2020 - 12:06 EST
Investigating
An issue is affecting access to the Faculty Information System (Elements) through My Pitt (my.pitt.edu) and AskCathy. Pitt Information Technology is aware of the issue and working to restore service as quickly as possible.

In the interim, users can still access the service by logging in to My Pitt, clicking Faculty Information System, then clicking the Home tab after the error message displays.

Updates will be posted as they become available. Please contact the 24/7 IT Help Desk at 412-624-HELP (4357) if you have any questions regarding this announcement.
Posted Feb 17, 2020 - 10:33 EST
This incident affected: Faculty Information System (Elements).