Vendor Issue Affecting PantherExpress (Jaggaer)
Resolved
Monitoring confirms the issue has been resolved.
Posted Aug 19, 2026 - 16:44 EDT
Monitoring
The vendor has taken steps to resolve the issue and restore service. Pitt Digital is monitoring closely to ensure continued reliability and stability.
Posted Aug 19, 2026 - 14:26 EDT
Investigating
Pitt Digital is aware of a vendor issue causing slow performance and access issues in PantherExpress (Jaggaer), the University's cloud-based purchasing tool and procurement and payment mechanism.
Pitt Digital is engaged with the vendor and working to restore full service as quickly as possible. Updates will be posted to status.pitt.edu as they become available.
Posted Aug 19, 2026 - 13:41 EDT
This incident affected: Human Resources and Financial Systems (PantherExpress (Jaggaer)).